By using Elementorforum.com’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the Best Wordpress and Elementor Support forum

    Provide or get advice on everything Elementor and Wordpress, ask questions, gain confirmation or just become apart of a friendly, like minded community who love Wordpress and Elementor


    Join us!
elementor official

I want to remove 'underline' from Text Links.

K

Kunal

New Member
Hi everyone,
Hope everyone is good in this global crisis.

I had a problem while developing a website on Elementor. While making a header on Elementor, I linked a text (Heading) to an URL and the text did not have an underline on that page.

Howwver, when I insert the same header section in another page of the website, the text gets underlined.

I have set the text decoration to None under typography but the issue still persists. :(

Please help. I want to get rid of this underline!

(I'm using Elementor for Free)
 
T

TinaB

New Member
OMG did you have any luck with this? I am going crazy trying to resolve.

I have gone to the global settings and changed it there still no luck :(
 
T

TinaB

New Member
Ok Kunal, so I've done it FINALLY!! I went to my theme customisation and put this in my CSS code a { text-decoration: non !important; } Hope it works for you too.
 
K

krishnagupta0122

New Member
Ok Kunal, so I've done it FINALLY!! I went to my theme customisation and put this in my CSS code a { text-decoration: non !important; } Hope it works for you too.
I am facing same issue.. i have also applied your css code in customisation but still it's not working.
 
C

Chris Amadi

New Member
Hi everyone,
Just in case this hasn't been resolved, you can simply remove the text-decoration( i.e that link underline) by changing the typography properties in the styles section of that particular element. Change decoration from default to none.
See the image attached.
 

Attachments

  • Screenshot 2021-09-06 at 23.53.29.png
    Screenshot 2021-09-06 at 23.53.29.png
    59.6 KB · Views: 787
Nephuxs

Nephuxs

New Member
This is a wordpress global secondary color issue that interferes with the Elementor builder using the BLANK template. Doing that will disallow you to turn off that underline.

I solved this by simply changing the theme of the site from BLANK to another template, in my case, Twenty-Two. Can confirm my site retained 99% of my build and underline is gone.
 
S

Simmosa

New Member
Hi Guys,
I solved this by going to Dashboard -> Appearance -> Customise -> Global -> Typography.
Scroll down to the bottom and unselect, "Underline Content Links"
 
I

Improv Poet Amy

New Member
On Hello theme by Elementor I do not have the global option, what else can I do? Also changed decoration to none and that didn't work either. This is the page I am trying to remove the underline under poet, New York Times etc (if you google improv poet and go to the footer "what is a singing telegram, then you can see my page, I am too new to post a link to it apparently)
 
Last edited:
I

im0130

New Member
On Hello theme by Elementor I do not have the global option, what else can I do? Also changed decoration to none and that didn't work either. This is the page I am trying to remove the underline under poet, New York Times etc (if you google improv poet and go to the footer "what is a singing telegram, then you can see my page, I am too new to post a link to it apparently)
The global settings can be found by pressing the accordion icon in the top left corner when editing with elementor. Then you can go to Site Settings --> Typography and set link decoration to none.
Hope this helps!
 
I

Improv Poet Amy

New Member
Thanks for that, I found that a few days ago and it worked. :)
 

Latest Resources

Other Elementor Resources

elementor official
Top