By using’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the Best Wordpress and Elementor Support forum

    Provide or get advice on everything Elementor and Wordpress, ask questions, gain confirmation or just become apart of a friendly, like minded community who love Wordpress and Elementor

    Join us!
elementor official

Elementor disables Hestia theme



New Member
Hi there,

everytime I create a new site on WP using Hestia Theme, it looks in default like this:
But when I want to fill it with content and use Elementor, the page looks like this, after opening elementor on the page:

So it looks like Hestia theme is disabled, but I create the elementor content in the white box you see on the first pic.
I use the latest versions of WP, Hestia and Elementor.

Do you know any fix?? Or maybe had the same problem?

Kind regards

Last edited:


New Member
This may be a too-simple answer, but have you checked Elementor > Settings? Make sure that "Disable default colors' and 'Disable default fonts' are unchecked if you want to use the stylings from Hestia. You can still make page-specific changes on the Edit with Elementor screen.

Latest Resources

Other Elementor Resources

elementor official